Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Died, after 50 levels of botting in same place without issues
02-28-2016, 07:17 PM (This post was last modified: 02-28-2016 07:20 PM by Catar.)
Post: #1
Died, after 50 levels of botting in same place without issues
Yup, something must be definitely wrong with the bbot's healer right now, and way he is using potions.

My ek just died.
Last time it was like 50 levels ago, which is 2 months.

   


And here is video, of my script running around spawn
I figured i'll share it with you, maybe u see something interesting.
Or macro bots uses that you may want ;D




(I made that clip, couple days ago)
Give Reputation to this user

Before you PM me, READ THIS [Image: KHCf9l2.png]

[Image: naLmyGH.png]

My Scripts, Macros and Tutorials
Find all posts by this user
Quote this message in a reply
02-28-2016, 08:26 PM
Post: #2
RE: Died, after 50 levels of botting in same place without issues
I've a very important estion:

What's this OTServer? I wanna play lool
Give Reputation to this user

Visit this user's website Find all posts by this user
Quote this message in a reply
02-28-2016, 08:50 PM (This post was last modified: 02-28-2016 09:24 PM by Catar.)
Post: #3
RE: Died, after 50 levels of botting in same place without issues
That's, unexpected.
What made you wanting to play ?

It's Hexera
10.90

_______
Replied to your email
Give Reputation to this user

Before you PM me, READ THIS [Image: KHCf9l2.png]

[Image: naLmyGH.png]

My Scripts, Macros and Tutorials
Find all posts by this user
Quote this message in a reply
02-29-2016, 01:15 PM
Post: #4
RE: Died, after 50 levels of botting in same place without issues
Ohh I reproduced the bug, but it took more than 5 hours to happen Sad
Give Reputation to this user

Visit this user's website Find all posts by this user
Quote this message in a reply
02-29-2016, 02:11 PM
Post: #5
RE: Died, after 50 levels of botting in same place without issues
which bug? with healer not working properly?
Give Reputation to this user

Before you PM me, READ THIS [Image: KHCf9l2.png]

[Image: naLmyGH.png]

My Scripts, Macros and Tutorials
Find all posts by this user
Quote this message in a reply
02-29-2016, 02:53 PM
Post: #6
RE: Died, after 50 levels of botting in same place without issues
Yes, apparently healer and attacker stops, randomly, after long periods.
Give Reputation to this user

Visit this user's website Find all posts by this user
Quote this message in a reply
02-29-2016, 04:53 PM
Post: #7
RE: Died, after 50 levels of botting in same place without issues
u owe me blessings then ;D
Give Reputation to this user

Before you PM me, READ THIS [Image: KHCf9l2.png]

[Image: naLmyGH.png]

My Scripts, Macros and Tutorials
Find all posts by this user
Quote this message in a reply
02-29-2016, 09:25 PM
Post: #8
RE: Died, after 50 levels of botting in same place without issues
I bot now 15acc for 12h every day and haven't seen any of them in temple xD so I didn't seen the bug. 45 ms on crystal spiders or 180 ed on grimvale die by 2 sec without healer
Give Reputation to this user

SELL 300 ED
Find all posts by this user
Quote this message in a reply
03-01-2016, 05:52 AM
Post: #9
RE: Died, after 50 levels of botting in same place without issues
Ed heals with spells, as you can see my ek its heavy reliant on HP potions, and problem is with bot wrongly prioritizing HP and mana potions when getting heavy burst from 10 elementals
Give Reputation to this user

Before you PM me, READ THIS [Image: KHCf9l2.png]

[Image: naLmyGH.png]

My Scripts, Macros and Tutorials
Find all posts by this user
Quote this message in a reply
03-01-2016, 11:22 AM
Post: #10
RE: Died, after 50 levels of botting in same place without issues
Aaaa I know now. So how you setting mana potions percentage ? I different beetwen drink from to drink till mana. Like 55% - 56% or 55% - 70% ?
Give Reputation to this user

SELL 300 ED
Find all posts by this user
Quote this message in a reply
03-01-2016, 12:47 PM
Post: #11
RE: Died, after 50 levels of botting in same place without issues
Yes, the problem with my script was that it got out of potions on the start of the cave, so it did the entire cave without potions and died.

But there are that bug that the prioritization of mana potions are not good, the suggestion is to make healing/mana drinking conditional when attacking/not attacking. This is on Trello.

Unfortunately there's still a bug that makes the bot stop attacking, I'm trying to figure out why it is happening.
Give Reputation to this user

Visit this user's website Find all posts by this user
Quote this message in a reply
03-01-2016, 02:16 PM (This post was last modified: 03-01-2016 02:16 PM by vmoreno94.)
Post: #12
RE: Died, after 50 levels of botting in same place without issues
I died yesterday because bbot was only using mana potions and exura ico when i had 80 health potions on my bp too, so there's a bug.
Give Reputation to this user
Find all posts by this user
Quote this message in a reply
03-01-2016, 03:11 PM
Post: #13
RE: Died, after 50 levels of botting in same place without issues
(03-01-2016 12:47 PM)MegaNo0body Wrote:  Unfortunately there's still a bug that makes the bot stop attacking, I'm trying to figure out why it is happening.

You mean it taking longer time to attack monster ? Cuz I only recorded that bug on new version.
Give Reputation to this user

SELL 300 ED
Find all posts by this user
Quote this message in a reply
03-01-2016, 07:06 PM (This post was last modified: 03-01-2016 07:40 PM by Catar.)
Post: #14
RE: Died, after 50 levels of botting in same place without issues
(03-01-2016 11:22 AM)damiansnk Wrote:  Aaaa I know now. So how you setting mana potions percentage ? I different beetwen drink from to drink till mana. Like 55% - 56% or 55% - 70% ?


I keep my mana on EK high (73-79 %) , so he can perform full utito gran ico and other high mana consuming spells combo and still have few hundred mana left.

I set up attack spells (macros used by adv attack) to never, under no circumstances go under 100 mana. Because if that ever happends, bot stops for some reason using mana potions at all.

On video you can see how my knight uses his spells and potions.

Using Exura ico to 92% hp (and not use if under 140 mana)
exura gran ico on 30% (actually never seen it beeing used)
Strong health potions (getting them them from concentrated blood) - from 85%
and UHP from 66%

* First items - Variation 3%


My EK died, (I am assuming, by the location of body, between 2nd and 3rd Hill - 10 second of wideo) when he got surounded by couple massive, and fire elementals), He spammed all mana on exura ico, and didn't use his exori or exori gran for unknown reason (it basicly oneshots all fire elementals)
Bot should prioritise using Healing potions while getting heavly damaged while using his mana to quickly kill threat.

Also, if u noticed, that Hud information - Killer START and Killer STOP.
Is my macro that decides if he should or should not start attacking.
It is always Killer START on higher floor (on hills).
Now in lower floor, where all the Fire elementals are.
Its killer START when hellhound on screen, or
When more than 8 monsters in 5 sqm range or
when standing still for 2 seconds with at least 2 creatures beside (which is not enough to kill this level of knight)
Give Reputation to this user

Before you PM me, READ THIS [Image: KHCf9l2.png]

[Image: naLmyGH.png]

My Scripts, Macros and Tutorials
Find all posts by this user
Quote this message in a reply
03-01-2016, 10:53 PM
Post: #15
RE: Died, after 50 levels of botting in same place without issues
How u set potions drinker ?
Strong light and great heavy ?
Have u tick box first potion heal ?
Show me ss plx with ur healer life and mana boxes
Give Reputation to this user

SELL 300 ED
Find all posts by this user
Quote this message in a reply
03-02-2016, 08:54 AM (This post was last modified: 03-02-2016 09:11 AM by Catar.)
Post: #16
RE: Died, after 50 levels of botting in same place without issues
Im did say everything already.

Can't send ss now, im on my phone.
There are only 2 combo boxes for healing potions. Syu that's obvious how they are setup (read my previous post)

Mana I use in heavy mana potion. when I tried to use it as medium or light it often stop using them at all.



Off-topic: using speech to text with your phone is pretty funny, surprisingly accurate

I had run my 280 paladin script last night, and it worked all night without a problem because paladin heals with spells( salvation)
Of course it is much slower than my Knight with a two handed 54 atk weapon
Give Reputation to this user

Before you PM me, READ THIS [Image: KHCf9l2.png]

[Image: naLmyGH.png]

My Scripts, Macros and Tutorials
Find all posts by this user
Quote this message in a reply
03-03-2016, 12:21 AM (This post was last modified: 03-03-2016 12:39 AM by damiansnk.)
Post: #17
RE: Died, after 50 levels of botting in same place without issues
Healer&Mana (auto: 1000ms)
1000 {Healer&Mana} Self.Health%()<=80 [manas] Self.Health%()>=60 [hpp] Self.Mana()>=40 [manas] Self.Say(exura ico) Exit() {manas} Self.Mana%<=80 Tibia.SendKey(116) Exit() {hpp} Tibia.SendKey(117) Exit()


f5 mana potion use on urself
f6 hppotion use on urself
Give Reputation to this user

SELL 300 ED
Find all posts by this user
Quote this message in a reply
03-03-2016, 06:53 PM (This post was last modified: 03-03-2016 06:54 PM by damiansnk.)
Post: #18
RE: Died, after 50 levels of botting in same place without issues
Did you checked that macro ? I've been strongly stoned yesterday when I wrote it. I tested and worked good (or just looks good)
When hp is beetwen 60-80 % and mana 40+
Bot use exura ico
If mana is below 40 points use hotkey f6
If hp is below 60% use hotkey f6
If mana is below 80% and hp above 60% use mana potio and exura ico
Give Reputation to this user

SELL 300 ED
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)